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About Coyote

Coyote is a powerful and versatile image capture application that lets you quickly configure your 
iPORT IP Engine and begin capturing images with your PC.

This software guide describes Coyote’s functionality in intricate detail. However, it isn’t a goal-oriented 
guide. To learn how to use Coyote to connect to your iPORT IP Engine, connect to your camera, and 
acquire images, see the iPORT Quick Start Guide. To learn how to use the powerful PLC to create a 
sophisticated machine vision system, see the iPORT Programmable Logic Controller Reference Guide. 
To learn about important concepts related to your IP Engine, see the iPORT Concepts Guide.

Overview of Coyote
Generally, you use Coyote as follows:
1. Use the Connection tab to connect to your iPORT IP Engine and camera. See “Connection tab” on 

page 12.
2. Use the File > Save command to save your IP Engine’s settings as a Coyote configuration file. See 

“Main menu” on page 9.
3. Use the Acquisition tab to display camera images on your PC. See “Acquisition tab” on page 13.
4. Optionally, use the Image Saving tab to save acquired images. See “Image Saving tab” on page 15.
5. Optionally, use the Diagnostic tab to find the cause of any acquisition problems you might have.   

See “Diagnostic tab” on page 17.
6. Optionally, use the Configuration dialog to configure image width, binning, and pixel type; define 

how the IP Engine and host PC communicate; and program the PLC. See “Configuration dialog” 
on page 19.
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Menus and tabs

This section describes Coyote’s menu options, tabs, and other functionality in intricate detail. 

For a description of Coyote’s dialogs, see “Coyote dialogs” on page 19.

NOTE! Coyote dynamically changes options and available configurations. Thus, screen shots may 
vary depending on your model of iPORT IP Engine.

In this section: 
Main menu ................................................................................................................... 9
Connection tab ........................................................................................................... 12
Acquisition tab........................................................................................................... 13
Image Saving tab ....................................................................................................... 15
Diagnostic tab ............................................................................................................ 17

Main menu
Coyote has menus for File, IP Engine, Camera, Tools, and Help.

The lower right-hand area has the Configure button.

Configure
Display the Configuration dialog. See “Configuration dialog” on page 19.

In this section:
File menu ................................................................................................................... 10
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10   Menus and tabs
IP Engine menu.......................................................................................................... 10
Camera menu ..............................................................................................................11
Tools menu..................................................................................................................11
Help menu.................................................................................................................. 12

File menu

To access:
• From the main menu, select File.
The File menu lets you create and save commands for XML configuration files for your iPORT IP 
Engine and camera.

The File menu contains:

New
Clear configurations and cached file names from the Connection tab (if any previous open or 
save has been performed).

Open
Open a dialog for selecting an XML configuration file. Check Ignore connectivity 
information to use your IP Engine’s current IP address. In the Coyote configuration file, you 
can identify the complete connectivity information by the <connectivity> tag. 

Save
Save As

Save the current configuration to an XML configuration file.

Exit
Close Coyote.

IP Engine menu

To access:
• From the main menu, select IP Engine.
The IP Engine menu lets you send commands related to controlling the iPORT IP Engine.

The IP Engine menu contains:

Reset
Reset the iPORT IP Engine (equivalent to powering the unit off and on).

Test network connectivity
Test that the network connection between the PC and IP Engine works.

Reconnect
Reconnect to the currently selected IP Engine.
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Save to flash memory
Opens the Save to IP Engine’s Flash Memory dialog. When an IP Engine supports this 
feature, this command saves the current configuration to flash memory and makes it the default 
boot-up configuration. See “Save to IP Engine’s Flash Memory dialog” on page 45.

Pulse Generators
Opens the Pulse Generators dialog for modifying the PLC’s pulse generator outputs on the 
fly. See “Pulse Generators dialog” on page 45.

Serial COM Port Link
Opens the Serial Port Configuration dialog. See “Serial Port Configuration dialog” on 
page 46.

PLC Control Bits
Opens the PLC Control Bits dialog. See “PLC Control Bits dialog” on page 44.

Camera menu

To access:
• From the main menu, select Camera.
The Camera menu lets you send commands related to controlling the camera.

The Camera menu contains:

Reset
Reset the camera (or other video source), if applicable. The video source is reset, but you may 
have to update the iPORT IP Engine.

Tools menu

To access:
• From the main menu, select Tools.
The Tools menu lets you change Coyote options and access other programs.

The Tools menu contains:

Set PLC Interrupt count to 0
Set the Count value in PLC Interrupts in the Acquisition tab to zero. To learn more, see the 
Interrupt FIFO section in the iPORT Programmable Logic Controller Reference Guide.

Run Information Gathering Tool
Run the Information Gathering Tool. This tool gathers information about your system into a 
single text file. The tool gathers driver information, network information, SDK versions infor-
mation, available IP Engines, and your XML configuration file. To use the Information 
Gathering Tool, see the Technical Support section in the iPORT Quick Start Guide.

Run Driver Statistics Tool
Run the Driver Statistics Tool. This tool can be used to troubleshoot network problems when 
using the iPORT High-Performance IP Device Driver.

Run Driver Installation Tool
Run the eBUS Driver Installation Tool. This tool lets you update and install all of Pleora’s 
iPORT IP Device drivers, as well as the driver supplied by Intel for the PRO/1000 Adapter. See 
the eBUS Quick Start Guide.
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12   Menus and tabs
Options
Open the Options dialog. This dialog lets you control the settings and behavior of Coyote. See 
“Options dialog” on page 39.

Help menu

To access:
• From the main menu, select Help.
The Help menu lets you see helpful information about Coyote.

The Help menu contains:

About Coyote
Display the About Coyote dialog containing information about the version of Coyote.

Connection tab
To access:
• Select the Connection tab.
The Connection tab lets you edit the configuration of the IP Engine and camera.

Connect
Communicate with your camera after you have detected an IP Engine and selected a camera.

Disconnect
Stop communicating with your camera and IP Engine; and clear the configurations in the IP 
Engine settings pane and Camera pane.

IP Engine settings pane
IP address

The IP address of the currently selected IP Engine.

Detect
Open the IP Engine Selection dialog which searches the network for available iPORT IP 
Engines. When you select an IP Engine, the information appears in the IP Engine settings 
pane. See “IP Engine Selection dialog” on page 37.
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Device name
The name of the currently selected IP Engine. To set this value, see “IP Engine tab” on 
page 27. 

Status
The connection state of the currently selected IP Engine.

MAC address
The MAC address of the currently selected IP Engine.

MAC address (NIC)
The MAC address used by the network interface card (NIC)

Communication mode
Specifies which driver is used to make the connection to the video source or camera.

IP Engine connection options pane
Connection Flags

Open the Connection Flags dialog. See “Connection Flags dialog” on page 36.

Multi-target
Open the Multi-Target Configuration dialog. See “Multi-Target Configuration dialog” on 
page 38.

Network Ports
Open the Network Stack Port Selection dialog. See “Network Stack Port Selection dialog” on 
page 38.

Camera pane
Camera type

The type of camera attached to the currently selected IP Engine. 

Select
Open the Select Camera dialog which lets you choose a camera configuration. See “Select 
Camera dialog” on page 46.

Acquisition tab
To access:
• Select the Acquisition tab.
Copyright © 2008 Pleora Technologies Inc.



14   Menus and tabs
The Acquisition tab lets you acquire images from the currently selected and connected IP Engine. 
Images appear in a separate window.

Control pane
Mode

This drop-down menu specifies the acquisition mode. Settings include:

Grab – Single
Acquire a single image from the IP Engine.

Grab – Continuous
Acquire images continuously until you click Stop.

Recording
Record the next frames into the IP Engine’s onboard internal memory until either the 
memory fills up or you click Stop. Images can be transmitted using one of the 
“playback” acquisition modes.

Playback – Single
Acquire a single image from the IP Engine’s onboard memory. If no frames are 
available, a timeout occurs.

Playback – Continuous
Acquire images continuously from the IP Engine’s onboard memory. When no more 
frames are available, timeouts occur.

Current channel
The video input channel the IP Engine uses for the Acquisition tab. Most IP Engines support a 
single channel (single camera) but DLV-series IP Engines and some ANL-series IP Engines 
support two channels. If the IP Engine supports a single channel, this field is disabled; for 
multi-channel IP Engines, use channels 0 and 1.

Number of frames
Specify the number of images to grab when using Grab – Single or Playback – Single mode.

Start
Start acquiring images based on the Mode. The image display depends on Coyote’s settings. 
See “Display Options tab” on page 43.

Stop
Halt any current acquisition.
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Options pane
Keep partial images

Accept images that are missing pixels or lines. Use this option when the image size is unknown 
or variable.

Don’t request lost packets
By default, missing packets are requested until they’re successfully delivered. By enabling this 
option, lost packets are ignored and never retransmitted. Images that are missing packets will 
appear incomplete, but you minimize bandwidth use.

Status pane
Display rate

The current and average rates of display in frames per second and the image ID for the last 
displayed image. The rate is a cumulative value from the time the Start button was last 
pressed, not an instantaneous rate. The image ID is assigned by the iPORT IP Engine.

Acquisition rate
The current and average rates of acquisition of the iPORT IP Engine, in frames per second. The 
acquisition rate is a cumulative value from the time the Start button was last pressed.

Image count
The total number of images and the number of incomplete images. A large number of 
incomplete images may indicate a set-up or cable problem.

Last error
The last error that occurred when acquiring images from the iPORT IP Engine. 

PLC interrupts
The Host PC Interrupt count; last input mask, and timestamp at the time the IP Engine 
generated the last interrupt. To learn more about PLC interrupts, see the iPORT Programmable 
Logic Controller Reference Guide.

Image Saving tab
To access:
• Select the Image Saving tab.
The Image Saving tab lets you save images in a variety of formats, including bitmapped images and 
movies. If you save the images as a movie, you must specify the filename and Codec (coder decoder). If 
Copyright © 2008 Pleora Technologies Inc.
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you save the images individually, Coyote automatically names each file by individual frame ID; you 
need specify only the directory.

To save images, you must be currently acquiring images using the Acquisition tab. (See “Acquisition 
tab” on page 13.) However, you can configure the Image Saving tab and click Start, then configure the 
Acquisition tab. Coyote won’t save images until you click Start in the Acquisition tab.

Image sequence pane
Continuous

Save images indefinitely until you click Stop.

Fixed
Save a finite number of images.

Number of images
The number of Fixed images to save.

File format pane
Text file with acquired image IDs

Save only the image IDs into a single text file.

Raw data files
Save each acquired frame into a raw, unformatted data file (.RAW). The format depends on the 
grabber’s image and pixel settings output. See “Image tab” on page 26 and “Pixel tab” on 
page 28.

Windows BMP files
Save each acquired frame as a Windows bitmap.

Movie
Save the acquired frames into a single AVI movie file using the Codec you specify.

Codec
The coder/decoder for the Movie.

File location or name
The directory for sequential images (files are named by image ID) or the directory and 
filename for a text file or movie.
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Controls pane
Start

Begin saving images.

Stop
Interrupt the process of saving images.

Progress
A bar that visually indicates the level of completion when saving a fixed number of images. 
When continuously saving images, the bar isn’t used.

Diagnostic tab
To access:
• Select the Diagnostic tab.
The Diagnostic tab provides basic information about the success of the image acquisition.

Controls pane
Start

Begin diagnosing the IP Engine connection.

Stop
Interrupt the diagnostic process.

Save
Save the results as a text file.

Statistics pane
The Statistics pane provides a running count of the images and image-related errors for both valid and 
invalid images. Valid images may have errors if Keep partial images is checked. See “Options pane” 
on page 15.

Count
The total number of images.
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Frame overrun
The IP Engine needs a few clock cycles to finish a frame. This error occurs if a new frame 
starts before the IP Engine has finished the previous frame.

Grabber FIFO overrun
The grabber ran out of RAM while acquiring an image. At least one section of the image is 
missing.

Image dropped
The total number of images dropped by the IP Engine. When a camera transmits images faster 
than the IP Engine can relay them to the PC, the IP Engine drops the image. The next image 
has an image-status bit set to indicate that the previous image was dropped. 

Partial line missing
The number of times a part of a line was missing in the IP Engine (i.e. not sent by the camera). 
The value is incremented only once per image, even if all lines in the image are partial. 

Full line missing
A complete line is missing from a frame. This error may occur with images of variable length.

Expected resend count
The number of packets (image pieces) that were re-requested and received.

Ignored packet count
The number of packets received by the PC were ignored due to the lack of an available buffer. 
Packets unrelated to IP Engine data aren’t counted.

Lost packet count
The number of packets that were expected, but weren’t received within a certain time limit or 
in the expected order.

Resent request count
The number of packets re-requested by the PC.

Start packet count
The number of packets the PC received (and ignored) while waiting for the first image packet.

Unexpected resent count
The host PC re-requests packets that haven’t arrived within its time limit. If both packets 
ultimately arrive, the second is counted as unexpected and discarded.

Errors pane
Error Types

The total number of errors. Click Show to see a detailed list in the Error Type dialog.

Missed Image IDs
The image ID of the last missed image. Click Show to see a full list in the Missed Image 
dialog.
Copyright © 2008 Pleora Technologies Inc.
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Coyote dialogs

This section describes most of the dialogs available in Coyote. The dialogs are arranged alphabetically 
by name. For a description of the menus, tabs, and buttons used to call the dialogs, see “Menus and 
tabs” on page 9.

This section describes the followings dialogs:
Configuration dialog .................................................................................................. 19
Connection Flags dialog ............................................................................................ 36
Custom Tap Reconstruction dialog............................................................................ 36
IP Engine Selection dialog......................................................................................... 37
Multi-Target Configuration dialog............................................................................. 38
Network Stack Port Selection dialog ......................................................................... 38
Options dialog............................................................................................................ 39
PLC Control Bits dialog ............................................................................................ 44
Port Configuration dialog .......................................................................................... 45
Pulse Generators dialog ............................................................................................. 45
Save to IP Engine’s Flash Memory dialog................................................................. 45
Select Camera dialog ................................................................................................. 46
Serial Port Configuration dialog ................................................................................ 46
Set IP Engine IP Address dialog................................................................................ 48

Configuration dialog
To access:
• Click Configure.
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The Configuration dialog lets you configure the iPORT IP Engine and the camera to which it is 
attached. As with the rest of Coyote, the options and tabs that appear depend on your model of IP 
Engine.

The Configuration dialog includes the following tabs:
Grabber tab ................................................................................................................ 22
Grabber Extensions tab .............................................................................................. 24
Image tab.................................................................................................................... 26
IP Engine tab.............................................................................................................. 27
Pixel tab ..................................................................................................................... 28
Port Communication tab ............................................................................................ 31
RGB Filter tab............................................................................................................ 33
Tap Reconstruction tab .............................................................................................. 34

Configuration details
Although this manual describes many features and parameters, some aren’t included. To prevent error-
prone duplication, features that are documented in the SDK are omitted, but included in the Coyote 
dialogs. Most of these features are in the IP Engine tab. To read about these settings, see the CyDevice-
ExtensionConstants.h file in the iPORT C++ SDK Reference Guide.
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To see documentation for some features within Coyote:
• Click on the item.

The description appears in the window below.

Advanced and basic configuration pages
The Configuration dialog lets you hide some parameters for easier understanding. If all parameters on 
a tab are hidden, Coyote hides the entire tab.

The basic version gives you easy access to the most commonly used camera parameters, such as image 
width, image height, or test pattern.

The advanced version gives you access to extra features such as tap reconstruction, pulse generators, 
and the rescaler. 

To toggle between the advanced and basic configurations:
• Check or uncheck the Show advanced configuration pages check box at the bottom of the Con-

figuration dialog.
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22   Coyote dialogs
Multi-channel IP Engines and the Configuration dialog
If your IP Engine supports multiple channels and per-channel configurations, the Configuration dialog 
displays a tab for each channel. Tabs that affect both channels remain unchanged.

Grabber tab

To access:
• Click Configure. Select the Grabber tab.
The Grabber tab lets you configure how the grabber acquires images from the camera.
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Acquisition configuration pane
Pixel shifting

The type of pixel shifting to use when acquiring pixels from the camera. When pixel shifting is 
used, the grabber will grab pixels according to its pixel depth configuration, and then shift 
them by the number of bits required. Depending on the source pixel and the pixel configura-
tion, it may yield a smaller frame size, in bytes. For example, if the attached camera is sending 
10-bit pixels and the pixel shifter is set to 2, the resulting depth is 8 bits. In this case, the 
resulting buffer would shrink from 2 bytes per pixel to 1 byte per pixel. (Available on IP 
Engines with firmware Version 3.16 or higher.)

Memory water level
The amount of the onboard memory that can be used before the IP Engine sees that it is “full.” 
(Available on IP Engines with firmware Version 3.14 or higher.) The possible values include:

50%
75% (default)
87.5%
100% (not recommended)

Data port mapping
The mapping of data ports from the camera. This feature comes from the Camera Link specifi-
cation, but also applies to LVDS models as well. Refer to both the Camera Link specifications 
and your camera’s documentation for more details on the port mapping. (Available on IP 
Engines with firmware Version 3.16 or higher.) The possible values include:

C B A (default)
C A B
B C A
B A C
A C B
A B C

Max pending resends
If many packets are missing (likely due to a bad connection), the PC might endlessly try to 
request the retransmission of the same packets. This setting limits the number of packets the 
PC tries to acquire and keeps the PC from generating an endless list of packets. Once the limit 
is reached, Coyote drops the oldest packet from the list.

Insert metadata in image
When enabled, the IP Engine replaces the first 4 bytes of every image with the image ID (in 
little-endian format). 
The image ID can also be determined using the CyBuffer::GetReadImageID function, but only 
after all the data packets for the image have been transferred. Enabling this feature lets 
software programs get the image ID after receiving the first packet (at the expense of losing a 
4-byte section of the image). 
Instead of the image ID, you can insert the PLC’s counter value in the image. To control the 
type of information in the 4 bytes, use the Grabber Extension tab. See “Grabber Extensions 
tab” on page 24. (Available on IP Engines with firmware Version 3.53 or higher.)

Invert pixel data
When enabled, the grabber inverts the bits of each acquired pixel. Black pixels become white; 
white pixels become black. (Available on IP Engines with firmware Version 3.16 or higher.) 

Trigger configuration pane
Frames to skip

The number of frames that the iPORT IP Engine will skip between successively transmitted 
frames. A value of 0 sends all frames.
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Continuous pipe count
The number of frames that can be in the transmission-and-acquisition pipe. A frame is 
considered to be in the pipe from the moment it starts until its last packet is transmitted to the 
Ethernet link. When the specified number of frames is reached, the IP Engine will ignore any 
new frames from the camera until the number of frames in the pipe decreases.
In Continuous mode, the limit is set by the amount of onboard memory available in the IP 
Engine, rather than the number of frames in the pipe. The IP Engine acquires frames from the 
camera until the memory is filled up to the water-level setting. See “Memory water level” on 
page 23.

Force single shot
When enabled, Coyote continuously requests single images from the iPORT IP Engine. 
Otherwise, Coyote asks the iPORT IP Engine to send images continuously until stopped.

PLC triggerable
Use the PLC to trigger the grabber to acquire an image. The grabber uses output Q14 in the 
PLC Lookup Table. Note that the IP Engine is triggered, not the camera. This feature is useful 
for cameras that don’t support triggered acquisition. (Available on IP Engines with firmware 
Version 1.7 or higher.) 

Automatic internal retrigger 
When this mode is disabled, the IP Engine waits for the rising-edge of the FVAL signal to start 
acquiring, and stops acquiring when either the preset number of lines has been reached, or the 
FVAL signal falls. The engine then waits until the next rising-edge of FVAL to acquire the next 
frame. 
When this mode is enabled, the IP Engine waits for the rising edge of the FVAL signal to start 
acquiring frames. If the signal is still high when the preset number of lines has been reached, 
the IP Engine will start a new frame with the next lines inside the FVAL signal. This goes on 
until FVAL finally falls. The SDK buffer functions can tell the application if a buffer is full 
based on either a line count or the falling edge of FVAL.

Medium configuration pane
The Medium configuration pane lets you configure settings for the second IP Engine when Coyote is 
configured for Camera Link Medium Mode (see “Application Options tab” on page 40).

Medium mode
The readout format. For example, Half-Line (Engine 1: Left portion, Engine 2: Right 
portion) outputs the first half (left) of each line on Camera Link 1 and the right half on Camera 
Link 2.

Synchronization group
Setting used for systems that have multiple PT2000 series IP Engines connected to the host PC. 
Each PT20000 series IP Engine must have a unique number, so subsequent units would be 
numbered 2, 3, and so on.

Data port mapping
The mapping ports for the second IP Engine. See “Data port mapping” on page 23.

Grabber Extensions tab

To access:
• Click Configure. Select the Grabber Extensions tab.
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The Grabber Extensions tab lets you configure how the grabber interprets the DVAL, LVAL, and 
FVAL signals from the camera.

Serial Select
The UART used for serial communications with the camera. Only UART0 is currently 
supported.

Data Valid Enabled
When checked, the DVAL signal determines whether or not the pixel is kept. When unchecked, 
all pixels are kept.

Data Valid Polarity
Line Valid Polarity
Frame Valid Edge Polarity

When checked, the DVAL/LVAL/FVAL signal is valid when low, rather than high (for level 
sensitive). When checked for edge sensitive values, the signal is valid for a falling edges, 
rather than rising.

Line Valid Edge Sensitive
Frame Valid Edge Sensitive

When checked, the IP Engine is sensitive to the edges of the LVAL/FVAL signal rather than 
the level of the signal.

Clock Present
A read-only value that is enabled when the IP Engine is receiving a clock signal from the 
camera. This entry is useful for determining if the IP Engine and camera are properly 
connected.

Frame Valid Function
Line Valid Function

The functions used inside the IP Engine. You can use combinations of the original signal and 
signals from the PLC to create your own signal (particularly useful for line scan cameras).
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26   Coyote dialogs
Image tab

To access:
• Click Configure. Select the Image tab.
The Image tab lets you configure parameters related to image composition, such as windowing and 
image type definition. Settings applied in this panel may control both the camera and iPORT IP Engine.

Area of interest pane
To learn more about binning, decimation, and area of interest, see the iPORT Concepts Guide.

Width
Height

The width and height of a single image frame from the camera. These settings also determine 
the size of the image buffer.

Offset X
The starting column of a single image frame from the camera. The Width plus the Offset X 
must be within the range allowed by the camera.

Offset Y
The starting row of a single image frame from the camera. The Height plus the Offset Y must 
be within the range allowed by the camera.

Binning X
Binning Y

The horizontal and vertical binning values on the camera. Binning combines several pixels into 
a single pixel to improve the signal to noise ratio in the image (reduce the resolution, increase 
the dynamic range). For example, a Binning X value of 4 and a Binning Y value of 3 
combines 12 pixels into one “superpixel.”

Decimation X
Decimation Y

The horizontal and vertical decimation of the iPORT IP Engine. A value of one indicates that 
the IP Engine won’t perform decimation. Any other value causes the IP Engine to eliminate all 
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but the (n - 1)th horizontal/vertical block of pixels from the image. For example, a 
Decimation X value of 4 and a Decimation Block X value of 1 removes 3 pixels and keeps 1.

Decimation Block X
Decimation Block Y

The size of the horizontal and vertical block of pixels that are kept or removed. For example, a 
Decimation X value of 3 and a Decimation Block X value of 2 removes 4 pixels and keeps 2.

Image type pane
Camera Type

Sets the camera in line-scan or area-scan mode. 

Field order
When the pixel type isn’t interlaced, the IP Engine returns frames containing fields from the 
interlaced sources. The field mode setting will dictate which field to acquire. The possible 
settings are:

Grab the next field
The IP Engine acquires the next field, regardless of whether it is field 0 or 1.

Grab the next field 0
The IP Engine acquires field 0 next, ignoring field 1.

Grab the next field 1
The IP Engine acquires field 1, ignoring field 0.

Indeterminate windowing pane
Indeterminate width

When checked, the IP Engine uses the Line Valid Signal to determine the end of a line. When 
unchecked, it ends the line when the pixel count matches Width.

Indeterminate height
When checked, the IP Engine uses the Frame Valid Signal to determine the end of an image. 
When unchecked, it ends the image when the line count matches Height. 

IP Engine tab

To access:
• Click Configure. Select the IP Engine tab.
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28   Coyote dialogs
The IP Engine tab lets you configure many parameters, including the Programmable Logic Controller. 
To see the descriptions of the parameters, see “Configuration details” on page 20. For a full description 
of the PLC, see iPORT Programmable Logic Controller Reference Guide.

Pixel tab

To access:
• Click Configure. Select the Pixel tab.
The Pixel tab lets you select the pixel type for the current camera configuration. The selected pixel type 
is used to configure the grabber and the buffers.
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The Pixel tab takes camera DLL information and brings forward only the color spaces, pixel depths, 
and tap quantities supported by that camera, as well as the flags and options that apply to the selected 
color/depth/tap combination. You can also select the different conversion flags associated with the 
camera. These flags will be saved to the camera’s XML configuration file (see “File menu” on page 10).

Pixel pane
Color Space

The color space of the output signal. The possible values include: Grayscale, Bayer RGB, 
RGB Color, and YUV Color. The availability of the color spaces depend on what the selected 
camera supports. Coyote automatically includes Bayer RGB if the camera supports grayscale 
and has a Bayer filter on its sensor.
The dropdown includes an intuitive graphic representation of the color space options.

Pixel depth
The pixel depth for the selected Color Space.

Tap quantity
The number of taps on your camera.

Normalized
For 10, 12, and 14-bit pixel depths (i.e. those that aren’t multiples of 8), this check box 
indicates whether or not the IP Engine will normalize the data. When normalizing data, the IP 
Engine aligns the most significant bit (MSB) of the data with the MSB of a 16-bit word, and 
sets the least significant bit (LSB) to zero. When not normalized, each pixel data is stored on 
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the LSB of a 16-bit word. The example below shows a regular 10-bit pixel and a normalized 
one.

Packed
For 10-, 12-, and 24-bit pixel depths, this check box indicates if the data will be “packed” or 
not. For 10 and 12-bit depths, every two pixels of data are packed on 3 bytes (24 bits), instead 
of on two 16-bit words (32 bits). For 24-bit pixel depth, the data is actually packed on 24 bits. 
When this option isn’t selected for 24-bit RGB pixels, each pixel is stored on a double word 
(32 bits). 

Interlaced
Indicates whether or not the data from the camera is interlaced. When a source is interlaced, 
this option will grab the two fields from the source to generate a single frame. The application 
is then responsible for de-interlacing the data.

Format info
Open the Pixel Organization dialog containing a graphical representation of the pixel data in 
the buffer, as well as a text description. This information is useful for application developers.

Dual output format
This dropdown, which is available only with two-tap data, indicates how the data is expected 
to be generated from the camera. If the output format isn’t in the format assumed by the IP 
Engine, some software reconstruction will be required.
The possible output formats include:

2 taps, interleaved
The data of tap 1 is the even numbered pixels (0, 2, 4, etc.). The data of tap 2 is the 
odd numbered pixels. This is the default handling of tap data by the iPORT IP Engine 
and requires no reconstruction.

2 taps, segmented
The data of tap 1 is the left part of a line and the data of tap 2 is the right part.

2 taps, segmented, right inverted
Same as 2 taps, segmented, but the pixels of tap 2 arrive from right to left.

2 taps, segmented, left inverted
Same as 2 taps, segmented, but the pixels of tap 1 arrive from right to left.

2 taps, segmented, left & right inverted
Same as 2 taps, segmented, but the pixels of both taps arrive from right to left.

2 taps, dual lines
The data of tap 1 contains the pixels of one line and the data of tap 2 contains the 
pixels of the next line.

NOTE! If your IP Engine supports tap reconstruction, you should use it. Tap reconstruction reconfig-
ures data before it is transmitted by the IP Engine. Thus, Coyote doesn’t have to reconstruct the 
data image, reducing CPU usage. To learn more about tap reconstruction, see “Tap Reconstruc-
tion tab” on page 34.
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Matching pixel types
The available pixel types that match the selection criteria. Though most selections yield a 
single item, there are some odd cases where it is possible to have two or more.

Pixel ID
The pixel type identifier of the currently selected pixel type.

Available converters
Open the Pixel Type Converters dialog showing all the converters that are available from and 
to the currently selected Pixel Type. This information is useful if you’re developing an appli-
cation.

Conversion options pane
Starting Bayer pattern

The available Bayer patterns that can be used. Options include:

GRBG
GBRG
RGGB
BGGR

Note that when the selected item is changed, it affects the display if it is running, within about 
500 ms. Therefore, you can easily select the right pattern for the camera in use.

Adjust Bayer pattern based on the window offsets
Leave unchecked if your camera adjusts odd-numbered offsets (see Offset X and Offset Y in 
“Pixel tab” on page 28) to make them even. Thus, the Starting Bayer pattern accurately 
reflects the actual pattern sent by the camera.
Check this option if your camera allows odd-numbered offsets. Coyote adjusts the Bayer 
pattern to accurately reflect the pixel being sent. For example, a camera that sends a GRBG 
pixel with an Offset X of 1 is effectively sending a RGGB pixel.

Use 3 X 3 Bayer interpolation
When checked, use 3 x 3 interpolation instead of the faster 2 x 2 interpolation. The 2 x 2 inter-
polation is more CPU efficient, but is less detailed.

Invert fields when de-interlacing interlaced image data
When using interlaced images, this option indicates if the de-interlacer will use field 1 or field 
0 for even numbered lines.

Port Communication tab

To access:
• Click Configure. Select the Port Communication tab.
The Port Communication tab lets you communicate through the available ports of the IP Engine. 
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The Port Communication tab lets you send and receive commands from a camera. You can use the tab 
to configure and access any camera without a camera-specific interface.

Port selection pane
Port

The serial port to be used. The dialog supports two types of ports: serial interfaces and bulk 
interfaces. 

Configure
Opens the Port Configuration dialog. See “Port Configuration dialog” on page 45.

Send pane
The Send pane lets you communicate directly with the camera using the camera’s native command set. 

Send as
The format of the strings to be sent. Available options include:

ASCII
Transmit strings as typed.

Hexadecimal
Transmit in hexadecimal. The data must be formatted as two-character hexadecimal 
digits separated by a space. For example, “58 59 5A” actually sends “XYZ”.

Command
The serial string to send.

Append
The character or characters used to terminate a string. Can include:

CR
Add a carriage return to the ASCII string before sending it to the camera.

LF
Add a line feed to the ASCII string before sending it to the camera.
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NULL
Add a NULL character to the ASCII string before sending it to the camera.

Other
Add a user-defined character to the ASCII string before sending it to the camera. 
Specify the hexadecimal value in the Hex window.

Port specific parameter
This integer parameter is used as the “aInfo” parameter when sending commands. See the 
CyDevice::SendCommand section in the iPORT C++ SDK Reference Guide.

Receive pane
Display Format

The appropriate format for the Log. Can be ASCII or Hexadecimal.

Clear Log
Clears the Log.

Log
Displays data sent via the serial port to the camera.

RGB Filter tab

To access:
• Click Configure. Select the RGB Filter tab.
The RGB Filter tab provides the basic RGB gain and offset values available when using a color camera 
(RGB, Bayer, or YUV). The panel also provides mechanisms for white balancing images from the 
camera. You must be acquiring images to analyze them.

Coyote applies the gains and offsets; they aren’t applied in the IP Engine. The conversions may increase 
CPU usage.
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newColorValue = oldColorValue * gain + offset

Gains & offsets pane
Red Gain
Green Gain
Blue Gain

The multiplier used for each color value. The resulting value is the red/green/blue value 
multiplied by this value.

Red Offset
Green Offset
Blue Offset

The offset for each color value. The offset is added to each color value.

White balancing pane
Analyze

Capture one image from a continuous stream of images, analyze the color values, and 
recommend gain values to best balance the image.

Apply results
Automatically set the gain values that Coyote recommended with the Analyze button. 

Tap Reconstruction tab

To access:
• Click Configure. Select the Tap Reconstruction tab.

NOTE! Tap reconstruction isn’t a standard feature of iPORT IP Engines, but a semi-custom feature 
added to engines by customer request. An engineering charge may apply. The Tap Recon-
struction tab doesn’t appear for IP Engines without this feature. 

The Tap Reconstruction tab lets you enable and configure the IP Engine’s hardware tap reconstruction 
feature.
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Enable hardware tap reconstruction
When checked, the IP Engine enables its tap reconstruction feature. 

Reconstruction mode
This dropdown lets you select either a predefined reconstruction mode or a custom mode. The 
dropdown includes images that let you see the data arrangement for each selection.
By default, most of the options are disabled. To enable this dropdown: From the Configura-
tion dialog, select the Pixel tab. Set Tap Quantity to 2. Click Apply.

Your options depend on the Tap Quantity you select in the Pixel tab. See “Pixel tab” on 
page 28.
The possible values include:

1-tap
Data from the camera is from left to right.

1-tap, inverted
Data from the camera is from right to left.

2-tap, interleaved
Data from tap 1 contains even-numbered pixels and the data from tap 2 contains odd-
numbered pixels.

2-tap, segmented
Data from tap 1 contains the left portion of a line and the data from tap 2 contains the 
right portion.

2-tap, segmented, right inverted
Same as 2-tap, segmented, but pixels from the right portion arrive from right to left.

2-tap, segmented, left inverted
Same as 2-tap, segmented, but pixels from the left portion arrive from right to left.

2-tap, segmented, inverted
Same as 2-tap, segmented, but pixels from the both portions arrive from right to left.
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2-tap, dual lines
Data from tap 1 contains even-numbered lines and the data from tap 2 contains odd-
numbered lines.

4-taps, segmented
Tap 1 contains the left-most portion of a line, tap 2 contains the middle-left portion, 
tap 3 contains the middle-right portion, and tap 4 the right-most portion.

4-taps, segmented, inverted
Same as 4-taps, segmented, but the pixels of each segment arrive from right to left.

Custom
The tap output of the camera isn’t one of the predefined modes. The Custom Tap 
Reconstruction dialog appears. See “Custom Tap Reconstruction dialog” on page 36.

Sensor dimension
When using a camera where the taps are segments of a sensor (segmented), this parameter 
indicates the complete size of the sensor. A value of -1 indicates that the size of the windows 
(from the Image tab), will be used. This parameter is important when windowing is required. 
Coyote needs to know the size of each segment to properly adjust the range to grab from each 
tap.

Time multiplexed mode
When checked, taps arrive in two groups on two different pixel clock cycles. The first group 
arrives on the first clock cycle (n + 0), and the second group arrives on the subsequent clock 
cycle (n + 1).

Connection Flags dialog
To access:
• Select the Connection tab. Click Connection Flags.
The Connection Flags dialog lets you configure how your iPORT IP Engine acquires and maintains a 
connection.

Apply IP Address to IP Engine when connecting with a Coyote configuration file
Force the specified IP address onto the IP Engine. When enabled and loading a Coyote config-
uration file, the IP Engine takes the IP address specified in the file. 

Reconnect automatically if image acquisition timeouts occur
When enabled, Coyote automatically attempts to reconnect if it loses its connection with an IP 
Engine. When disabled, Coyote reports a timeout and waits for the connection to return. 
Disabling this flag may help with wireless networks, where connectivity isn’t always stable.

Send keep-alive packets (to notify firewalls that the port remains open)
When enabled, Coyote sends regular dummy packets to the IP Engine. The packets keep your 
firewall from automatically closing an idle connection after it times out.

Custom Tap Reconstruction dialog
To access:
• Click Configure. Select the Tap Reconstruction tab. In the dropdown, select Advanced.
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The Custom Tap Reconstruction dialog lets you set the tap geometry and segmentation for your 
custom configuration.

Tap quantity
Indicates how many taps the camera outputs. Options include:

2 taps, segmented
2 taps, interleaved
4 taps, segmented

These settings are the same as those in the Tap Reconstruction tab, however, you can 
customize the Tap Geometry for each tap (rather than using presets). For the defini-
tions, see “Tap Reconstruction tab” on page 34.

Tap 1 geometry
Tap 2 geometry
Tap 3 geometry
Tap 4 geometry

The direction of the tap output from the camera/sensor. The Tap quantity setting determines 
how many are enabled. Options include:

Left to right
Right to left

IP Engine Selection dialog
To access:
• Select the Connection tab. Click Detect.
The IP Engine Selection dialog lets you locate iPORT IP Engines that are connected to a host PC either 
directly or through a network switch.
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The Available IP Engines pane displays the IP Engines that each NIC found.

The IP Engine and NIC Information pane provides detailed information about any device you select 
in the Available IP Engines pane.

To select, click an IP Engine in the Available IP Engines pane, then click OK.

Multi-Target Configuration dialog
To access:
• Select the Connection tab. Click Multi-target.
The Multi-Target Configuration dialog lets you configure the IP Engine to send images to multiple 
PCs. You might use this option for machine vision applications where many PCs process images from a 
single IP Engine. To learn more about multicast, unicast, and multi-unicast modes work, see the iPORT 
Concepts Guide.

Multi-Target
The sending mode used when connecting to IP Engine. Note that this list box shows all the 
possible modes, since Coyote can’t determine the modes that are supported by the IP Engine 
until the connection is made. If you select a mode that isn’t supported, an error will occur 
during the connection sequence. See the iPORT Concepts Guide.

Group address
The multicasting group IP address, used only in multicasting mode. The usable IP addresses 
are restricted; see the iPORT Concepts Guide.

This application is the master
When enabled, the current PC will be the master client of the IP Engine. This applies to all 
modes, including unicast. When connecting a unicast client as a slave, Coyote won’t be able to 
configure or trigger the IP Engine. This is useful when connecting to an IP Engine that boots 
up in a streaming state.

Do not join group
Whether or not the multicasting master will join the group. When the master doesn’t join the 
group, it won’t receive any image data from the IP Engine. This mode is useful when a master 
PC controls several multicasting IP Engines, and the combined bandwidth exceeds the 
capacity of the PC’s Ethernet link and/or PCI bus. The master simply configures the IP 
Engines and camera(s), and then triggers the engines to stream their data.

Network Stack Port Selection dialog
To access:
• Select the Connection tab. Click Network Ports.
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The Network Stack Port Selection dialog lets you configure the UDP ports.

When using the network stack to bring data into the PC, you can specify which UDP ports will be used 
to connect to the IP Engine. The default port value of 0 causes the network stack to choose any available 
port. These values aren’t used when using the iPORT High-Performance IP Device Driver.

In some cases, you may want to force a port number to one or all of the three ports. For example, you 
can save IP Engine’s configuration to flash while it is streaming (see “Save to IP Engine’s Flash 
Memory dialog” on page 45). When the IP Engine boots up the next time, it starts sending frames right 
away. To ensure that the same ports are used, specify each port rather than letting the IP Engine choose 
available ports.

Command Port
The port over which commands from the host PC to the IP Engine (and acknowledgements 
from the IP Engine) are sent.

Data Port
The port over which images are sent from the IP Engine to the PC. For IP Engines with 
multiple channels, channel #0 uses dataPort; channel #1, dataPort + 1.

Interrupts Port
The port over which the IP Engine sends interrupts to the host PC. To configure interrupts, see 
the iPORT Programmable Logic Controller Reference Guide.

Options dialog
To access:
• From the main menu, select Tools > Options.
The Options dialog lets you set a large number of preferences and settings in Coyote.

The Options dialog includes the following tabs:
Application Options tab ............................................................................................. 40
Buffer Options tab...................................................................................................... 40
Connection Options tab ............................................................................................. 41
Display Options tab ................................................................................................... 43
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Application Options tab

To access:
• From the main menu, select Tools > Options. Select the Application Options tab.
The Application Options tab lets you configure the flow of dialogs until you have successfully 
connected to your IP Engine.

Show device detection dialog on startup
Open the IP Engine Selection dialog upon startup. See “IP Engine Selection dialog” on 
page 37.

Show camera selection after detection
Automatically open the Select Camera dialog after selecting an IP Engine. See “Select 
Camera dialog” on page 46.

Do connection after camera selection
Automatically connect after choosing a camera. Equivalent to clicking Connect. See 
“Connection tab” on page 12.

Go to acquisition tab after connection
Cycle to the Acquisition tab successfully connecting to an IP Engine. See “Acquisition tab” on 
page 13. 

Camera Link Medium Mode
Set Coyote in Camera Link Medium mode. See “Configuring your PT2000 series IP Engine 
(Medium mode)” on page 49.

Reuse last configuration on startup
Save the last used configuration to a temporary file and reload it when starting the application.

Select GEV over iPORT when possible
If your IP Engine supports the GigE Vision protocol, this option lets you automatically use that 
protocol over the iPORT protocol.

Buffer Options tab

To access:
• From the main menu, select Tools > Options. Select the Buffer Options tab.
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The Buffer Options tab lets you configure how the buffer queue behaves when acquiring images.

Buffer Queue Mode
Set the buffer queue mode. The queue mode indicates the behavior of the buffer when the 
queue is full and new images are acquired. Available modes include:

Remove first frame when full
When the buffer is full, discard the oldest images to make room for new ones.

Drop new frames when full
When the buffer is full, discard new images.

Queue Size
The maximum number of buffers in Coyote’s buffer queue. When the buffer queue is full and 
a new image arrives from the IP Engine, Coyote handles the new image according to the 
Buffer Queue Mode setting.

Memory usage threshold
The percentage of the PC’s total RAM memory available for holding images from the IP 
Engine. Once exceeded, an error prompt appears. Typically, a level of 50% or 75% works for 
most systems. 

Connection Options tab

To access:
• From the main menu, select Tools > Options. Select the Connection Options tab.
The Connection Options tab lets you configure how the IP Engine connects with the PC, the duration 
of timeouts, and so on.
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Default timeouts & packet size pane
Answer Timeout

The maximum time, in milliseconds, the IP Engine can take to respond to a command from the 
application.

Request Timeout
The maximum time, in milliseconds, the host PC waits to receive all the packets for a single 
image.

Packet Size
The maximum packet size, in bytes, that the IP Engine can use to send image data to the appli-
cation. When connected point-to-point with the iPORT High-Performance IP Device Driver, 
the maximum value is 8128 bytes. In networked applications, the value depends on the 
maximum packet size that can be accepted by the switches between the IP Engine and the host 
PC. If the switches can be configured to support jumbo packets, you can use the jumbo packet 
configuration to reduce packet overhead in the host PC. A packet size of 1440 bytes should 
work with all networking equipment.

First Packet Timeout
The maximum time, in milliseconds, the IP Engine can take to send the first packet of image 
data to the application. When zero, the timeout is calculated automatically from the request 
timeout.

Packet Timeout
The maximum time, in milliseconds, the IP Engine can take to send subsequent packets of 
image data to the application. When zero, the timeout is calculated automatically from the 
request timeout.

Command Retry Count
The maximum number of times Coyote retransmits an unacknowledged command to the IP 
Engine.
When Coyote sends a command to the IP Engine, the IP Engine transmits an acknowledge 
packet back to the PC (Coyote). If Coyote doesn’t receive the acknowledge packet within the 
time specified by Packet Timeout, it retransmits the command. The retry count doesn’t 
include the original command.

Automatic packet size detection
When enabled, the Coyote disregards the Packet Size configuration and negotiates the optimal 
packet size with the IP Engine.

Default heartbeat settings pane
The heartbeat function lets the IP Engine send data only when the host PC is properly connected to the 
network. Using the heartbeat function keeps the IP Engine from endlessly transmitting data to a PC that 
has long since disconnected from the network (due to power outage, network failure, etc.).

If the IP Engine doesn’t receive a heartbeat signal before the configured maximum time, it stops trans-
mitting (as if it received a stop request). To restart transmission, the PC must reconnect to the IP Engine 
and explicitly start transmission.

To learn more about the heartbeat function, see the iPORT Concepts Guide.

Normally, the IP Engine accepts heartbeat signals only from the PC to which it is connected. However 
in Multicast mode, the IP Engine accepts heartbeats from any PC because it can’t tell which PCs are 
part of the multicasting group (see “Multi-Target Configuration dialog” on page 38).

Heartbeat Expiration
The maximum time that the IP Engine waits for a heartbeat signal before stopping transmis-
sion. An expiration of 0 disables heartbeating.
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Heartbeat Interval
The interval between the transmission of each heartbeat packet from the PC to the IP Engine. 
For proper operation, this value must be lower than the Heartbeat Expiration. 

Display Options tab

To access:
• From the main menu, select Tools > Options. Select the Display Options tab.
The Display Options tab lets you configure how Coyote displays the image window when you begin 
acquiring images.

Display mode pane
Enable display

When enabled, each successful grab operation displays its image data in a display window. If 
the window is closed, it will be opened on the first grab operation. When disabled, grab 
operations are performed without displaying the image data.

Display fullscreen
When enabled, and the display window isn’t already opened, the display window will be 
opened as full screen. Use the Escape key to get out of the full screen mode. On a system 
with multiple monitors, you can select on which monitor the full screen window appears.

Color mode
The color order for the display. Available options include:

Display adapter uses BGR
Coyote adjusts its output to use Blue, Green, and Red ordering. Most adapters use this 
format.

Display adapter uses RGB
Coyote adjusts its output to use Red, Green, and Blue ordering.

Synchronize with monitor’s refresh rate
When enabled, Coyote tries to match the image acquisition rate with your monitor’s refresh 
rate (such as not exceeding your monitor’s rate, etc.).

Display memory pane
Display memory type

The type of memory used by the display adapter. Available options include:

Use video memory of the display adapter
Display uses the video memory of the display adapter.
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Use system memory
Display uses the system memory of the PC. Use this mode if you encounter display 
problems when using the adapter’s video memory, particularly when big images are 
being displayed on smaller display sizes (for example, a 4K x 4K image is being 
displayed on a 1280 x 1024 display). Note that this mode might impact CPU and 
resource usage. 

PLC Control Bits dialog
To access:
• From the main menu, select IP Engine > PLC Control Bits.
The PLC Control Bits dialog lets you read and change the values of the PLC control bits of the IP 
Engine. To learn more, see the iPORT Programmable Logic Controller Reference Guide.

PLC Control Bit status pane
The PLC Control Bit status pane lets you set the values of PLC_CTRL0 through PLC_CTRL3. To 
learn how to use these bits, see the iPORT Programmable Logic Controller Reference Guide.

Set value
The value you request. Enabled is equivalent to a value of 1. Changes are sent immediately.

IP Engine value
The value polled from the IP Engine. These values let you confirm that the Set value was 
actually implemented on the IP Engine. Though Set value request packets are instantaneously 
applied in the IP Engine (allowing for network propagation times), the polling for confirming 
the values is slower.

Broadcast requests to all IP Engines
When enabled, commands to set or clear a PLC control bit are sent to all IP Engines on the 
network. Only the changed value is sent and IP Engines with PLC control bits already set at the 
new value aren’t toggled.

IO Block status pane
The IO Block status lets you see the values of A0 through A3 on the IO Block. These values are inputs; 
though the actual input type (TTL, etc.) depends on your model of IP Engine. The values are polled at a 
rate of roughly 4 Hz. Thus, fast signals and short pulses may not appear to change (though the changes 
occur properly on the IP Engine).

To learn how to use these input signals in the PLC, see the iPORT Programmable Logic Controller 
Reference Guide; to see the pinouts for your IP Engine, see your hardware guide.
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Port Configuration dialog
To access:
• Click Configure. Select the Port Communication tab. Click Configure.
The Port Configuration dialog lets you configure the port characteristics for serial port communica-
tion.

Configuration Edit box
Edit box in which the port configuration string is to be typed. The format of the string depends 
on the port type being used. 

Format
Open a dialog that provides a quick reference for the configuration string format. This 
information is also available in the iPORT C++ SDK Reference Guide.

Pulse Generators dialog
To access:
• From the main menu, select IP Engine > Pulse Generators.
The Pulse Generators dialog lets you set the PLC’s pulse generators on the fly. To learn more about 
the pulse generators, see the iPORT Programmable Logic Controller Reference Guide.

Save to IP Engine’s Flash Memory dialog
To access:
• From the main menu, select IP Engine > Save to flash memory.
The Save to IP Engine’s Flash Memory dialog lets you select which information is to be saved in the 
flash memory of the unit.
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IP Engine’s IP Address pane
Save current setting

The IP Engine saves its current IP address, the mask, and the default gateway to flash.

Use DHCP/BOOTP
The IP Engine automatically retrieves an IP address when it boots up. Depending on the type 
of IP Engine, it can get its address from a DHCP/BOOTP server or use LLA (Link-local 
address) from a directly connected host.

IP Engine’s name
Save current setting

The IP Engine saves its current name (the name is only informational).

No name
The IP Engine saves no name (even if it currently has one).

IP Engine’s configuration
Save configuration

The IP Engine saves information such as the PLC’s settings, the camera’s settings, and settings 
you find in the Configuration dialog.

Use default boot-up configuration
The IP Engines saves no configuration information. When the IP Engine boots up, its default 
values are unchanged.

Select Camera dialog
To access:
• Select the Connection tab. Click Select.
The Select Camera dialog lets you choose a camera implementation. The dialog displays the cameras 
that match the module and sub-module ID of the currently selected IP Engine.

Serial Port Configuration dialog
To access:
• From the main menu, select IP Engine > Serial COM port link.
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The Serial Port Configuration dialog lets you communicate with the IP Engine through a serial port 
on your PC.

Some older camera configuration programs can only communicate with the camera through a PC COM 
port. To let you use these legacy programs, you can connect your IP Engine to a second COM port and 
cable the two COM ports together. Windows supports virtual COM ports, so the COM port need not be 
an actual physical port on your PC.

If you’re controlling the camera through a physical COM port, cable the two ports together using a null-
modem cable.

If you’re controlling the camera through a virtual COM port, use a virtual serial port driver and connect 
the two COM ports together. You can find good virtual serial port drivers at: 

• http://www.softinfinity.com/
• http://www.virtual-serial-port.com/.

Device serial port configuration pane
Baud Rate

The speed of the serial communication for the COM port and the IP Engine. 

Bits
The data size for the COM port. At present, IP Engines support only 8 bits.

Parity
The parity of the serial communication for the COM port and the IP Engine. Can be set to 
None, Odd, or Even.

Stop
The number of serial stop bits for the COM port. 
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System serial port configuration pane
Port

The serial COM port to which the SDK is attached.

Set IP Engine IP Address dialog
To access:
• Select the Connection tab. Click Detect. In the right window, right-click an IP Engine and click 

OK.
The Set IP Engine IP Address dialog lets you configure or change the IP address of an IP Engine.

If there is a BOOTP or DHCP server on the network, iPORT IP Engines may already have been given 
an IP address. It is your responsibility to ensure each IP Engine has a unique IP address.

IP Engine Settings
MAC address

The MAC address of the device. This address is unique and can be used for IP Engine identifi-
cation.

IP address
The current IP address of the IP Engine. It can be modified to change the IP address of the IP 
Engine.

Subnet mask
A mask used to determine which subnet the IP address belongs to. To obtain the subnet 
address, Coyote performs a bitwise AND operation on the Subnet mask and the IP address.

Gateway
The IP address of the device on the network that sends local traffic to other networks.
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Configuring your PT2000 series IP Engine
(Medium mode)

The Base Configuration of the Camera Link standard uses a single Camera Link cable to transmit data; 
the Medium Configuration uses two. All iPORT IP Engines support the Camera Link Base Configura-
tion.

The PT2000 series of iPORT IP Engines supports the Camera Link Medium Configuration. In most 
respects, the PT2000 works as two individual IP Engines, however you must configure the two IP 
Engines to synchronize the data between each other. 

Configuring Coyote for an IP Engine (PT2000 series)
Before connecting to your PT2000 series IP Engine, you must enable Coyote to connect to IP Engines in 
Camera Link Medium Configuration.

To configure Coyote for Camera Link Medium Configuration:
1. From the main menu, select Tools > Options.

The Options dialog appears.
2. Select the Application Options tab.

3. Check Camera Link medium mode.
4. Click OK.

Coyote is now ready to connect to a PT2000 series IP Engine using the Camera Link Medium Con-
figuration.

Connecting to your iPORT IP Engine (PT2000 series)
Generally, the connection procedure for a PT2000 series IP Engine is the same as that for a Base Con-
figuration IP Engine. However, when you connect to your IP Engine, you must connect to two IP 
Engines rather than one.

Coyote assumes that the first device is the one that performs the following tasks:
• Serial port communication with the camera;
• Acquisition triggering; and
• PLC signal handling.
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The two IP Engines inside your PT2000 series unit have consecutive MAC addresses. When prompted 
for the two IP Engines, you must choose the IP Engine with the lower MAC address first. The IP Engine 
with the lower MAC address is physically located closer to the power and PLC connectors.

To connect to your IP Engine:
1. Follow the usual procedure for connecting to an IP Engine. (See the iPORT Quick Start Guide.)

Where the IP Engine Selection dialog usually appears, the IP Engine Selection - Medium mode - 
1 of 2 dialog appears instead. Except for the dialog name, it is visually identical.

2. Select the IP Engine with the lower MAC address and click OK.
Once your first IP Engine is selected and configured, the IP Engine Selection - Medium mode - 2 
of 2 dialog appears.

3. Select the IP Engine with the higher MAC address and click OK.
4. Continue with the usual procedure for connecting to an IP Engine.

Except for minor exceptions, Coyote treats a Camera Link Medium Configuration camera in 
exactly the same way as a Camera Link Base Configuration camera.

Configuring your iPORT IP Engine (PT2000 series)
Most Coyote configurations apply to both IP Engines within the PT2000 series IP Engine. However, 
some tabs within the Configuration dialog will have two sections, one for each IP Engine. Ensure you 
properly configure all the extra sections. See “Configuration dialog” on page 19.

Tabs of particular interest include:
• IP Engine tab (See “IP Engine tab” on page 27.)
• Grabber Extensions tab (See “Grabber Extensions tab” on page 24.)
• Grabber tab (See “Grabber tab” on page 22.)
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For additional help, see the Technical Support section in the iPORT Quick Start Guide.
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